Sudden 502 Bad Gateway Issue with APIs during Live Demo
Resolved
Sep 15 at 01:00am IST
The issue has been solved and the rate limit has now been increased to 2000RPM to a single IP Address to better meet large scale requirements.
Affected services
api.worqhat.com
Updated
Sep 14 at 09:22pm IST
The main issue behind the faults has been identified as Rate Limit Errors. The current rate limits to the request had been set as 100RPM (Requests per Minute).
Due to the number of requests being over 150 at the same minute, it created an improper Rate Limit Error that wasn't handled correctly and led to a 502 Bad Gateway Error.
We have identified the error and are working actively to resolve it.
Affected services
api.worqhat.com
Created
Sep 14 at 05:30pm IST
During the Live Demo with an approximate crowd of ~150 people, the API Endpoints started running into 502 Bad Gateway Issues. Potential causes of errors are:
- Database over utilised and rejected further responses
- API Server over utilised and rejected further responses
- 429 Request Error / Rate Limit Error Not Handled Properly on the Server's End (High)
Affected services
api.worqhat.com